CLI Wallet to bridge stuck


I have just synchronized my wallet with version, according to your documentation, my balance should have been sent automatically to the bridge, but when I use the “show_transfers” command I have a transaction which remains stuck at " pending out" corresponding to my balance sent but the transaction remains blocked. See attached file. Can you help me please?

mine stuck for 4 hours. check the block explorer for confirmations. you should see an increasing confirmation number there. put your new wallet address in the search field of

The explorer doesn’t work correctly, I put my address in the legacy explorer and it says balance 0 TX 0, while on my CLI fully synchronized I have my balance and transactions. 3 days stuck for now and nowhere to trace the transaction

have you made the etn-sc wallet using your old wallet’s spendkey?

I tried but it didn’t work, when I use etn-sc I can’t write the commands, I tried Metamask but the chain ID is not working…

what command you can not write?
if you mean that while you typing you don’t see the letters you typed appearing then it happened to me to. you should type tthe whole command and press enter then it will appear

That’s it, I managed to import my private key with the command “etn-sc account import /path/to/your/raw_priv ate_key.txt” but I can’t type “etn-sc attach” in the etn-sc console, we cannot write in, I tried your solution but still nothing

etn-sc is a node, for syncing the smart chain and connecting to using a client. (either another instance of etn-sc or metamask). Sounds like you are trying to enter commands into etn-sc when its running as a node.

Whats your public address user2? Have you checked the legacy blockchain to see if it bridged?

This is my public key :


The legacy block explorer show 0, but I have a balance on my CLI Wallet.

Where I can enter the command if I can’t in etn-sc?

is it a paper wallet or just in CLI user2? i.e. do you have the 3 keys (public/spend/view) noted somewhere safe. (goes without saying, do not give them to ANYONE or post them anywhere)

It’s from a paper wallet, I have the 3 Keys, I have import them in the CLI wallet, and synced the Blockchain, I can see my balance with a tx transfer ( see the picture attached in my first post )

OK… firstly dont worry.

So when you import your paper wallet into CLI, 2 things will happen:

  1. if the paper wallet is old (coins sent to it years ago) it will first create a “Migration” transaction. This is part of the update a few years ago which removed privacy. They will then show in Block Explorer when you search for your public address. Thats why yours doesnt show as you mentioned above… that hasnt happened.

  2. It will then create a “Bridge” transaction. Which sends your coins to a bridge address where they are basically destroyed. Then on the new smart chain, the bridge will send the same amount of ETN to an address which was created using the Spend Key from your paper wallet. That way only you can take control of them on the new smart chain.

Both of those are automatic…happen when you sync your wallet against and up-to-date node.

From what you are describing/showing, none of this has happened.

That transaction in your screen show is from years ago… the reason it shows as pending is your wallet hasnt/isnt refreshed.

Is your electroneumd node synced and up-to-date? What does it say if you type “status” into it.

Thank you for these clear explanations. I am fully synced, see the attach file.
May be I can send the coin manually to the bridge?

Can you paste those transaction codes to save typing. (next to amounts)




Did you import this paper wallet now and refresh from block 0? or is it an existing CLI wallet you did before?

I import the paper wallet in the first, waiting for sync and launch the after. I try to do a rescan on the

Yeah try “rescan_bc hard 0” first. That will scan from scratch… Make sure you are using for electroneumd and CLI of course.

Yes sure, I start to rescan I will keep you informed, thanks for your help, it is really appreciated.

1 Like


Well it looks like the first step is finally working, I saw the migration to bridge in explorer. Rescan from 0 on the is mandatory for the migration.

Now I’m going to try to understand why I can’t add the ETN network to Metamask, I have this error “impossible to retrieve the chain ID. Is your RPC URL correct?”

Is it working for you on Metamask?