Blockchain sync issues

My previous thread was closed after a couple days for some reason, so I have had to make a new one.

I am trying to sync the blockchain so that I can access my funds in a paper wallet.

The blockchain.raw file is out of date and doesn’t work as mentioned by Chris_ETN.

I have since tried to sync from block 1 as mentioned by another member using version 3.0.0.0

The issue I have is that it keeps stalling after 200-300 blocks are done and has remained at ~38 days out of sync for the past 2 days, I can keep restarting the process by closing and restarting electroneumd.exe and it will sync another 200-300 blocks before it stops.

Other than doing that repeatedly for several weeks, I see no other way of sync the blockchain within a reasonable time.

@BegaMutex any idea :point_up::point_up::point_up::point_up:

I had the same issue. I think the blockchain.raw file needs to be updated for the latest fork.

What OS are you using? If its a linux box, you might be running out of memory and need to create a virtual RAM disk??

I ran it on Windows 10 machine. Nothing to do with the memory.

Anti-virus maybe???

1 Like

I had issues with Malwarebytes for the cli.exe file, but, I included it in the safe list in Malwarebytes. I think the problem started in version 3.

Running it on a windows 10 system, absolutely no issue previously to version 3.0 with blockchain sync.

Just done a test with windows 10 with a samsung ssd disk. From block 1. No problems. Up to block 6000.
With version 3.0.0.0.
Keep in mind that it is 40+ Gb file.
At block 6000 test aborted
by me

1 Like

I’m at block 566488 where its taking an eternity to sync each chunk. Upwards of 20-30 minutes per 100 blocks, it randomly stops requiring me to restart the program.

This is again windows 10, on a 250gb ssd with 50%+ space free still.

Try typing set_log 1 to show more verbose error messages

and sync_info to check how many nodes you are connected to

Take a look at your windows electroneum log file, on a windows installation it is usually located at:
C:\ProgramData\electroneum\electroneum.log
(it’s best to open large logfiles in notepad++ instead of standard notepad)

A)
Is your copy of blockchain database allowed to resize whenever needed?
If not, I would guess AV is preventing your daemon from changing this file on disk

In your log-file look for something similar to this:
LMDB memory map needs to be resized, doing that now.
LMDB Mapsize increased. Old: 25988MiB, New: 27012MiB

B)
If your are not connected to at least 8 peers (nodes) I would guess there is some kind of firewall issue preventing your node from exchanging info with other nodes on the network

1 Like

Exit blockchain save and then exit.
Run electroneumd.exe with adminstrator.
think you know that.
Try using a different internet connection. with LAN or vice versa with WiFi.
If all goes well you get the choice of private networks or public. I checked private network.
I thought you saw ISP … GmbH and the location was in a different country.
Perhaps something is wrong there.
Good luck

I also think what RSKNOR said you should look for it.

Ok this might seem a bit irrational, but previously when setting this up I downloaded the blockchain.raw
(said fully downloaded) with Firefox and my setup failed.

I tried re-downloading with Firefox (again, said fully downloaded) and setup again and freeze half way through.

Eventually I decided to download with Chrome and setup and it worked.

Don’t ask me what I’m implying here. I just know this apparently post hoc ergo propter hoc fix worked.

If you’ve used Firefox to download the Blockchain.raw - give Chrome a try instead, if you guys are still encountering issues.

1 Like

I am doing it the Step 1 way, running the electroneumd.exe, from start. right now, it’s 531 days behind. It has been running for more than 4 hours now. so far so good, hasn’t crashed yet. I am going to let it run and see.

1 Like