Yoti requires Android Lollipop 21 (I can't use it)


#1

My phone has Android version 4.1.2. When I go to download Yoti Google Play store says “your device isn’t compatible with this version”. To use Yoti I will have to get a new phone running Android Lollipop 21. That is a bummer.