Ubuntu Dependencies for v4

Hi,

I’ve just tried to update to v4 on my Ubuntu 18.04 LTS server and get the following error message:
./electroneumd: /lib/x86_64-linux-gnu/libm.so.6: version ‘GLIBC_2.29’ not found
(required by ./electroneumd)
./electroneumd: /lib/x86_64-linux-gnu/libc.so.6: version ‘GLIBC_2.28’ not found
(required by ./electroneumd)

It seems like these need Ubuntu 19.04 and above and no clear instructions on how to get around.

Has anyone found a solution to this as I’d rather not upgrade the OS at this stage.

Thanks.

1 Like

Looks like an issue open on github already (unless that was you ofc M44FFW).

I expect the devs will provide feedback there.

2 Likes

No, that wasnt me.

Thank you - I thought I’d checked Github for issues. I really shouldnt try multitasking and listening to a call while updating my remote node!!

Thanks for pointing this out for me.

2 Likes

Perhaps add a comment to the issue, so they can see multiple people having same issue. :+1:

2 Likes

I just upgraded to Ubuntu 20.04 and everything worked fine. My remote node is now running v4 of the daemon and I’ve tested it with the old v3.3 cli and the new v4 and it works with both

2 Likes
Community Terms | Main Terms & Conditions | Privacy Policy | Support Tickets | Main Website