Mandatory level 1 Yoti for new users


#1

Does anyone know if there was any change in Kyc levels? I indicated the Electroneum for several people who do not have affinity with this world and now many of them are being required to install Yoti and to register. The big problem is that here in Brazil only allows passport and many do not have. There is some change in relation to the three levels of KYC?


#2

Someone to help? It’s happening to a lot of people.


#3

As of 27/12/2018 there was a change.

All I can say is create a support ticket.