Importing the Blockchain to Electroneum CLI


#1

Step 1

Download the official raw blockchain here: https://downloads.electroneum.com/blockchain.raw

Step 2

Find the path of your Electroneum cli wallet (the folder where you extracted your wallet). For example mine is:

C:\electroneum-win-x64-v2.1.1.0

Step 3

Find the path of your downloaded raw Blockchain for example mine was:

C:\blockchain.raw

Step 4

Open a Command Prompt window. You can do this by pressing the Windows key + R, and then typing in the popup box CMD

Step 5

Now you need to navigate using the CMD window to the path of your Electroneum cli wallet. You can do this by typing:

cd C:\YOUR\ELECTRONEUM\WALLET\FILE\PATH\HERE

It should look something like:

cd C:\electroneum-win-x64-v2.1.1.0
image

Step 6

Now type in your command prompt window:

electroneum-blockchain-import --input-file C:\YOUR\RAW\BLOCKCHAIN\PATH --verify 0

For example I would type :

electroneum-blockchain-import --input-file C:\blockchain.raw --verify 0

Step 7

After the the Blockchain has finished syncing up you can open your Electroneum CLI wallet normally. Your downloaded blockchain.raw can be deleted.

Blockchain Data Location

  • Mac: /Users/YourName/.electroneum/lmdb/data.mdb
  • Windows: C:\ProgramData\electroneum\lmdb\data.mdb
  • Linux: /home/user/.electroneum/lmdb/data.mdb

Electroneum CLI wallet guide with Remote Node method
CLI wallet integrity
Cli wallet closes when i try to open. was working before
Electroneum CLI wallet guide with Remote Node method
#2

hi, every time I type : set_daemon nodes.hashvault.pro:26968
and responded with: Daemon set to hashvault.pro:26968, untrusted

how can I get a truested daemon>?

thanks


#3

@cuddlesquid i tried it but doesn’t work .i did it with the slow way and it works (after I couldn’t do it with this way I just waited for 4 days to synchronizing and now I m using it ) i thing the issue with importing the 10 gb file to cli folder .have a nice chance


#4

Whats the error when you try importing the raw blockchain?


#5

Remote Node guide is here:


#6

i don’t remember but its made me angry :grin: so i waited for more 3 days and get all thing works normally .


#7

lol, makes sense furious @furios :joy:

Just give me a hint if you would like me to setup a ftp-server so you can download a copy of the .RAW export of the full-node 28.4 Gb database


#8

Yeah actually i synchronized it with slow way so i think it’s the best way for that try it .i tried both ways then I deleted everything and started from zero :rofl: I think the slow way is the best way to do that in my case :wink:


#9

I already make all this steps dear


#10

Gotcha. In order to set daemon node this way, it might have to be provided by the Electroneum developers. Unfortunately I can’t help us with this situation, but I could assist you with something else to make your life easier so you don’t have to type in the command all the time.

We can create a batch file and simply put the remote node command in it. Next time you want to open wallet you would simply click open the batch file, here is how to create one.

  1. Open Notepad program on windows.

  2. Copy and paste the remote node command into notepad.
    electroneum-wallet-cli.exe --daemon-host=nodes.hashvault.pro:26968

  3. Click FIle then Save-As

  4. Change ‘Save as type’ to ‘All Files’

  5. Type in ‘hashvault.bat’ as file name.

  6. Save the batch file inside Electroneum wallet directory.

  7. Double click on saved batch file to open Electroneum CLI wallet from remote node.


#11

Thanks for reply
Before I start with those steps dear sir
I have encountered a new problem is that Windows does not respond to any file and shows me the message that the following:

This app can’t run on your PC
To find a version for your PC, check with the software publisher

What to do

Regards


#12

Is there any chance you can screen shot the error? Also which executable (.exe) are you trying to launch?

Ensure you have the latest Electroneum CLI client which can be found here:

  • If for windows, download the electroneum-win-x64-v2.1.1.1.zip

#13


#14

@Kuwaity Thank you for screenshot. Unfortunately this seems like a Windows related issue, and I may not be able to help you, but what I can do for now is direct you to a couple of links so you can get familiar of whats going on.

Also, is your Windows install x32 bit or x64 bit? Our CLI is only available in the x64 bit version. If you are unsure, follow these instructions to check: https://www.tenforums.com/tutorials/4399-see-if-system-type-32-bit-x86-64-bit-x64-windows-10-a.html

Link 1: https://www.kapilarya.com/fix-this-app-cant-run-on-your-pc-windows-10

Link 2: https://windowsreport.com/app-cant-run-windows-10/

Fair piece of advice, do not download any 3rd party software to fix this type of issue, ensure you are only performing legitimate changes to your windows and only performing windows updates to eliminate this issue, or perhaps a full reinstall of Windows 10 (x64 bit version).


#15

thanks boss I will try it ( am in the x64 )


#16

When i try to import the blockchain with that file it hangs forever at block 77350


#17

why does my anti-virus responds and deletes the electroneum.exe data from the cli wallet?


#18

Because it sees it as a virus, even if it isn’t. You have to put an exception in your antivirus for the folder containing the exe file or for the exe file itself.


#19

it still hangs at the same block 77350


#20

It really shouldn’t hang unless you have something installed/running on your Windows that’s somehow interfering with block sync,… CPU usage is quite high while blockchain is syncing.

May I ask, how long have you left it hanging at block 77350? And have you tried restarting electroneumd.exe ?