Get Yoti KYC lvl2 if ID not accepted?


You’d to uninstall the app and reinstall it, on the google play store when you go to install it the app it will ask for permissions. I am guessing you can reject the camera access in order to do that. Although I can’t see how that would enable any manual upload on the profile settings.


Precisely… how can we upload to electroneum site if it doesnt show in the profile area…


No need to reinstall the app, you can turn it off in your device settings, search apps select Electroneum and you’ll see the permissions you can then turn it off, I’d also suggest to uninstall YOTI before uploading documents, I did all this process solely on my smartphoneand it worked. Let me know if it helps. Good luck :crossed_fingers:


My phone doesn’t allow me to disable permissions on the app, it just says what permissions Electroneum has.

I see why now, just due to the fact i’ve got a older android that’s only 5.1.1 app permissions weren’t introduced until 6.0 so at least on this phone it’s a no go I will just wait until it’s been situated by the Electroneum team.


After turning off the camera, I have to uninstall YOTI… Then, where should I go and what should I do?


Print a bank statement which is no longer than 3 months, take a picture of it then head to Once there, login. You’ll have to solve some captchas, then you’ll be propmted to enter your PIN, enter it and you should be able to access “My profile tab”.From there just upload your photo of your bank statement.


Went to settings in then, to “your profile”… No other icon to click where I can upload bank statement…


Unfortunately for the best combability you’ll need to upgrade your phone. Android 7.0 and up work fine. People with older versions of Android have been having the same issues. I personally recommend a phone with Android 8.0 to be on the safe side.


How sure are you Sir that it applies to Android 7.0 and up only? If I buy a new Android 7.0, is it sure that I can be level 2 and 3 verified without going to YOTI app??


I’m saying that for security reasons, older versions don’t get any security or firmware updates from Android and are at risk.


Ok… By the way, I checked my Android version its 7.0 but still the alternative way or option you suggested/provided didnt work. Unfortunately, it didnt.


I have a totally different screen, I guess it’s based on your brand etc. Sorry I failed you people :confused:. For more information contact the support team


No need to apologize. You did a great job in offering a possible alternative solution to be KYC level 2 and 3 verified without going to yoti app which yielded a positive result for you. I tried the process on how to go about it, but it didnt work for me. Unlike the support or moderator or those called “genius”, did not provide any concrete details of any alternative solution on how to overcome the problem. They just ignore the message or refer you to a link or post fb messages on KYC or whatever without offering/providing any specific options on how to solve the problem. Thanks a lot Sir @Anth!


Thanks all for the tips

I simply do not see an option to upload documents, under the profile tab or anywhere else.


I think you making fool people I have tried it to latest version android as same way you mention but no any upload option their . If there is alternate Solution without "Yoti " then " Electroneum Authority " or Richard should message about this. every one who have no Passport are waiting for Alternative. Don’t just fool people.


Have you contacted Electroneum support to be added to basic Yoti.



I’ll just keep my etn in paper


Hopefully an easier alternative is released soon sorry for the inconvenience. Pm me if you want to try further to complete


yoti just keeps declining my drivers license , i have sent it about 50 times in all different lighting and it keeps sayind my license was not accepted!! they need to fix this can’t complete KYC so i won’t buy ETN until it is fixed!!!