ETN Not Opening


#1

Please help! I have been trying to open my electroneum app but to no avail. I started experiencing this after I upgraded the app to the latest version. Thanks for your kind assistance.


#2

Hi @00ad6166364d6285384d have you tried restarting the device then logging back in ?

If that doesn’t work try uninstalling the app and starting over .


#3

Okay, thanks very much, I will just do that asap


#4

Could it be due to the KYC? Is there a warning about KYC on the screen?


#5

No, there is nothing like that, thanks


#6

No, it can’t be because isn’t still obligatory KYC form


#7

I have tried all the options suggested here but to no avail


#8

Can you tell us what device and firmware you are on could be an app problem . In the mean time try logging into my. Electroneum.com wallet


#9

Create a support ticket Via this address

https://support.electroneum.com/servicedesk/customer/portal/3/user/login?destination=portal%2F3

They will sort it for you.
There is a menu it has options
Look for app or mobile miner select that then tell them the issue your having and they will have a solution for you…


#10

I don’t have any problem logging into my electroneum wallet, it is the app that has issue


#11

That’s what you have to tell support


#12

My device is Samsung galaxy note 3


#13

And the firmware? Would be worth to find out if it is a firmware problem