Downloading blockchain through gui wallet

i have enough network speed to download the blockchain but it always failed to download after around 7 gb is downloaded. download speed reduces to 10 kb per second after 8 gb and then it completely stops in 11 gb

Not sure how network speed comes into it when syncing kc4knc ?

You sure you dont mean you are downloading the bootstrap raw version?

i clicked on something like extra features i don’t remember

image

OK, still not sure how kb/s come into it… thats not shown anywhere within the GUI.

Anyway, ok so things to look out for:

  • Does the drive its being saved to have enough space on your computer? (You can see the location in:
    Settings->Node(top)->Blockchain Location.
  • Does your computer have enough RAM? Performance is massively improved by higher RAM.

In the meantime, I would recommend switch to bootstrap mode.

Close the wallet:
image

Click Change Wallet Mode

Choose Simple Mode (bootstrap).

Pick the region you are in, and tick the tickbox.

Then Open your wallet again. This will run the wallet in Simple Bootstrap mode, which means you use a remote node while the blockchain downloads in the background. This way you can start using while you get the syncing issue sorted.

i have selected advanced mode btw i checked file size from the file explorer

i didn’t turn off my pc yet and it downloaded only 300 mb in one hour

That’s why i suggested you switch to bootstrap mode. It will download in the background but still allow you to use the wallet via a remote node.

So you don’t have to wait. It’s specifically designed for people without high spec machines/connections. :+1:

You could also download the RAW file and import…I think there is a guide on the forum somewhere.

i couldn’t find the tutorial

here Importing the Blockchain to Electroneum CLI

i created custom blockchain wallet directory while creating wallet what should i do now?

Add below to your import command:

–data-dir [your path]

…or just import to default location and copy and paste the lmdb folder after to your directory.

should i do this from etnd exe or cmd?

2020-06-14 14:25:37.558 4832 WARNING blockchain.db.lmdb src/blockchain_db/lmdb/db_lmdb.cpp:78 Failed to open db handle for m_hf_starting_heights : MDB_CORRUPTED: Located page was wrong type - you may want to start with --db-salvage
2020-06-14 14:25:37.558 4832 ERROR bcutil src/blockchain_utilities/blockchain_import.cpp:926 Exception at [Import error], what=Failed to open db handle for m_hf_starting_heights : MDB_CORRUPTED: Located page was wrong type - you may want to start with --db-salvage

salvage is not an executable, you dont run it on its own.

so what to do then? i can’t run daemon it stops constantly

@cuddlesquid help please

One thing you coudl try is to limit the number of blocks when syncing. This helps when you have low ram. In the Daemon startup flags try --block-sync-size 1 for a start. Increase if its running ok.

image

Failing that, as i suggested above, just run as bootstrap mode kc4. That way you can use the gui wallet now via remote node…and it will slowly download in the background…once it finishes downloading it will run in local mode.

Community Terms | Main Terms & Conditions | Privacy Policy | Support Tickets | Main Website