Cli wallet help needed


#1

I tried to create my wallet from my keys and it returned this answer with a zero balance. So it doesn’t show my etn. I tried to start the sync at a certain date, maybe I got the date wrong I’m not sure what to do or how to fix it. Please help me


#2

This is what it saI’d


#3

I think that you didn’t import your wallet keys /so you have to reenter your wallet backup keys and by the way, you have to full synchronized to the blockchain otherwise not all and last balance will appear


#4

out of sync would suggest you do not have the electroneumd running. Run that first and wait for it to sync the blockchain. Once that is complete, keep it running and then run the cli.


#5

I started it again. I did generate from keys and just used a different wallet name than last time. This time I didn’t select a block chain start heigth, I’m just letting it go through the whole thing to see if it finds my etn. Does it hurt to use the same keys for more than one wallet name like I just did? And I would like to thank you more experienced people for helping me!!


#6

As stated above, out of sync means you are not connected to Electroneumd.

You can use --generate-from-keys again with no problem, although it wasnt necessary, just load wallet-cli without the generate switch and it will ask the for the wallet name and password you chose. You can then rescan from the start on that. (rescran_bc i think is the command, check by running the help command in cli)


#7

Thank you @BegaMutex


#8

Don’t forget it’s possible to sync the wallet without downloading the whole blockchain via the remote node method described here.


#9

I had a similar problem of zero balance when generating a CLI wallet (likely private key issue) and using it.

Instead I added in a paper wallet with the keys (electroneum-wallet-cli --generate-from-keys ), updated the blocks and saved them (save_bc) but also had Electroneumd updated and running in the background, and now can see the balance and transfer etc.


#10

If you are viewing a paper wallet, you can keep it 100% safe by never using the private key and running the cli wallet in view only. (just use public and view keys). via --generate-from-view-key.

It will only let you see incoming transactions but gives you peace of mind that the coins reached the wallet and that you havent used your private key.


Would you like to check your paper wallet balance the easy way with maximum security?
#11

Too late I generated from all 3 keys, and everything was successful. Now hopefully my Antivirus will protect me.


#12

Would be good if you could do a video on CLI/paper wallet. Especially now given KYC/AML. Thanks