CLI/GUI Question

Hi! Please when I followed your guide up to where I had to supply my wallet address, private view and send keys.

The address was pasted and accepted correctly but I couldn’t paste my private view key to proceed.

I’m I missing something? Please kindly help.

Thanks.

1 Like

Hi, and welcome to the forum.

Which instructions have you followed? Can you post a link to them here and I’ll see what I can do to help

1 Like

For safety, the private key is not shown when its pasted/typed in…its a little disconcerting but it is there. Make sure there are no spaces and paste it in (& press enter i guess) :+1:

3 Likes

Really? Ok.

Maybe I should try it all over again

1 Like

Yup, you aren’t the first person who got tripped up by that step. :slight_smile: :+1:

3 Likes

I get this error after entering the wallet address, private send and view keys and password:

Error: wallet failed to connect to daemon: 52.138.176.219:80818. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the ‘set_daemon’ command.

EDIT: Ok, so I guessed I needed to change the IP address and it worked.

But right now, but I somehow managed to close the command line and when I try to steps again it says wallet has been created already “wallet”.

Please how do I open the previously created wallet which I think it’s named “wallet”?

Thanks. Total novice with this command line stuff.

1 Like

what are you entering when trying to load the CLI wallet?

This should be sufficient for a Windows machine:
electroneum-wallet-cli.exe --daemon-host=13.74.171.8:8081

If you’re in the right folder at a command prompt. In the folder you have your electroneum-wallet-cli.exe, do you see a file called wallet and another called wallet.keys??

2 Likes

Hey everyone. Going to give cli wallet a try. I want to use remote node method. So to create a new wallet I use: electroneum-wallet-cli.exe --daemon-address=52.138.176.219:80818. And then to access the wallet again, that’s the only line I use each time right? That same command?

1 Like

Yes.

There’s a “Wallet” and “Wallet.keys” file in the folder.

The command line is currently closed. How do I continue with accessing the wallet from here?

Thanks again for the assistance.

1 Like

Morning @user204

In the folder you can see your wallet and wallet.keys files, in a space in the folder, hold down shift and right click. In the menu that comes up, click on “Open Command Window Here” and then type in electroneum-wallet-cli.exe --daemon-host=13.74.171.8:8081

That’ll get you back into the wallet

2 Likes

Hi @Legend - wrong IP address, its electroneum-wallet-cli.exe --daemon-host=13.74.171.8:8081

1 Like

When I pressed SHIFT KEY and RIGHT-CLIK, what I saw was “Open PowerShell window here”.

So I decided to try opening my wallet by double-clicking the electroneum-wallet-cli.exe file, enter my wallet name and password and I was able to login.

Then I get the below message:

Error: wallet failed to connect to daemon: http:// localhost :26968. Daemon either is not started or wrong port was passed. Please make sure daemon is running or change the daemon address using the ‘set_daemon’ command.
Background refresh thread started
[wallet etnkMc (no daemon)]:

Please what does this mean? Thanks.

1 Like

That means its looking for the blockchain on your local machine and the daemon that downloads it and keeps it in sync is not running.

In your folder with all the files, right click on electroneum-wallet-cli.exe and then Create Shortcut. Then right click on the newly created shortcut and go to Properties. Click into the Target folder and scroll all the way to the right of it. At the end of the .exe, add in " --daemon-host=13.74.171.8:8081" without the quotes and then double click on that. It should start the wallet and connect to my remote node

2 Likes

@M44FFW thankyou for all your help!

2 Likes

Opening the new shortcut takes me to the same place as before with the same error. I tried to “refresh” and it seems that it will take quite some time to fetch the over 1 million blocks.

Did you add the extra bit with the IP address onto the end in the shortcut?

Can you post some screenshots please?

1 Like

Since I am using a remote node, I’m supposed to be fetching all the blocks?

It seems to be working now. It’s refreshing with about 1 million blocks to go.

The refresh was completed and I got this message:

[wallet etnkMc (out of sync)]: refresh
Starting refresh…
Refresh done, blocks received: 418431
Currently selected account: [0] Primary account
Tag: (No tag assigned)
Balance: 0.00, unlocked balance: 0.00
[wallet etnkMc]: refresh\

I’m not sure whether that means my coins are no longer in the wallet.

Yes. Please find attached the screenshot.

Good news :slight_smile:

You do need to sync the blocks but you don’t download a full copy of the blockchain. The full thing is about 50gb whereas your synced version will only be a few kb’s.

My remote node does go offline every now and again - the daemon just stops for no apparent reason. If that happens and you notice before I do, just nudge me here. Putting a monitoring service on it is just too far down my priority list at the moment!!

1 Like
Community Terms | Main Terms & Conditions | Privacy Policy | Support Tickets | Main Website